21 апреля 2019 г. 17:27:01

Нужно сделать апгрейд с 1.50 до 2.8

6 years ago
#998 Цитировать
Нужно сделать апгрейд с 1.50 до 2.8 конечно за дополнительную плату.....
0
6 years ago
#999 Цитировать
panso wrote:
Нужно сделать апгрейд с 1.50 до 2.8 конечно за дополнительную плату.....


Похоже опоздал, убрали Upgrade Script с оф. сайта для апгрейд до 1.9(а ведь были?) .... теперь только с 1.9 до 2.8(это  каждый сделает)
... а может база 1.5 запустится под версию 1.9
0
6 years ago
#1000 Цитировать
Можете найти обновление до последней версии на Codeplex http://nopcommerce.codeplex.com/releases/view/51059
Скачайте версию 1.9 source code. Перейдите в папку nopCommerce_1.90_Source.rar\NopCommerceStore\Install\Scripts\ там и найдётся обновление с версии 1.5
Если вы не меняли ничего в структуре баз данных, то обновление займёт у вас не более 30-ти минут

Удачи!
0
6 years ago
#1001 Цитировать
admin wrote:
Можете найти обновление до последней версии на Codeplex http://nopcommerce.codeplex.com/releases/view/51059
Скачайте версию 1.9 source code. Перейдите в папку nopCommerce_1.90_Source.rar\NopCommerceStore\Install\Scripts\ там и найдётся обновление с версии 1.5


... точно ЕСТЬ.

admin wrote:

Если вы не меняли ничего в структуре баз данных, то обновление займёт у вас не более 30-ти минут


.... ну очень оптимистично!
дело в том что 2.7 --> 2.8(mvc4) требует   ms vs 2012.(на оф. сайте NopCom пишут просто поставь ms vs 2012)
Ставим ms vs 2012, а Вам напишут на widows XP proff это не работает (ПРОЩАЙ widows XP proff СО ВСЕМИ ПРИБЛУДАМИ :)
Ставим ms server 2012 + ms vs 2012 + ms sql 2012(если менять то ВСЕ) - теперь попробуйте:
- установить NopCom ver.2.0 (mvc3)
- найти хостера у которого есть поддержка ms sql 2012(обратной совместимости баз нет)
.....
Смотрим на часы.. ОГО пару дней прошло :)
Я знаю... я делал.
Удачи.
0
6 years ago
#1003 Цитировать
Согласен с вами, но вопрос подразумевал обновление версии, к обновлению у вас всё должно уже быть установлено. Если у вас min Windows 7 и всё остальное, включая нормального хостера, то процесс не будет таким долгим.
0
6 years ago
#1007 Цитировать
admin wrote:
Согласен с вами, но вопрос подразумевал обновление версии, к обновлению у вас всё должно уже быть установлено. Если у вас min Windows 7 и всё остальное, включая нормального хостера, то процесс не будет таким долгим.


Что бы не путать(ся) нужно уточнить
admin wrote:
...вопрос подразумевал обновление версии.

Версии чего?
- если базы ------> то процесс не будет таким долгим.

- если сайта ------> то даже такую  мелочь как styles.css придется "ковырять"...

ver. 1.9
.product-grid .product-item .add-info .prices .productPrice
{
  color: green;
}

.product-grid .product-item .add-info .prices .oldproductPrice
{
  color: Red;
  text-decoration: line-through;
}

ver. 2.65
.product-grid .product-item .add-info .prices .product-price .price{color:green;}
.product-grid .product-item .add-info .prices .old-product-price .price{color:Red;text-decoration:line-through;}

... как говорят почувствуйте разницу :)
Ответ на главный вопрос
panso wrote:
Нужно сделать апгрейд с 1.50 до 2.8 конечно за дополнительную плату.....

...min 250 y.e.
0